Motorcycle Classics Blogs > Tech Corner

Tech Corner

Technical Q and A for classic motorcycle maintenance and repair.


1970 Triumph Bonneville Boyer Ignition Troubles

 Keith 

Editor’s note: If you’re having trouble with that old Suzuki, BSA or BMW, Keith Fellenstein is your guy. From motorcycle tuning tips to detailed motorcycle engine repair, he can draw from a wealth of experience to help guide you to success. Send questions to: Keith’s Garage, 1503 SW 42nd St., Topeka, KS 66609, or send an e-mail with “Keith’s Garage” as your subject. 

1970 Triumph Bonneville Boyer Ignition Troubles 

Q: I seem to be having the same issues on my 1970 Triumph Bonneville as David Ragland has on his 1966 model (Triumph T120 Ignition Trouble, March/April 2012). My coils are both new, as are the leads. I use N3 Champion spark plugs set to the correct spark gap. The problem is intermittent, depending upon how much low rpm riding I do. Just a couple miles at 30-35mph in high gear will bring on the problem. Then it might clear out once I am back to highway speed. What and where are the trigger coils and trigger wires? By the way, my Boyer ignition is new, as well. Thank you for sharing your expertise with us mortals. Had I not seen this reply to David Ragland I never would have considered that as a source of my problem. - Jeff Young/Tupelo, Miss. 

A: Back in March, David Ragland wrote in with a problem with his Bonneville fouling one plug. I suggested several causes and a few solutions and hoped he could figure it out. He called me the other day to update me on the issues. First, he found the Boyer ignition was grounded through the battery carrier, which is rubber-mounted so not a good ground. Once he got that squared away it started firing more reliably, but still fouled the left plug. He finally pulled the head and that’s when he found the real problem. A poorly done valve job had resulted in a split intake valve guide and badly ground valve seat. That cylinder was sucking oil down the valve guide and fouling the plug. He’s now in the process of having the valve job done correctly and is confident that will take care of the fouling.

Back to your problem. The trigger coils are mounted where the points used to be, under the round cover on the right side timing cover. Vibration can fracture the wires where they leave the printed circuit board, causing intermittent ignition.

What I really think is going on is that you are running rich at low throttle openings and fouling plugs. What you should do is install a new pair of spark plugs, throw a plug wrench in your pocket and go for a ride. Find a road with little traffic, preferably one with a slight incline and decent, wide shoulders. Ride along at the speed that causes your problem. At the first sign of trouble, hit the kill switch, pull in the clutch and coast to the shoulder. Pull the spark plugs and inspect the insulators. If you find them to be sooty black then the carburetor is running rich at that throttle opening. It sounds to me like this will be happening at small throttle openings, so it could be any of three things. The idle circuit, the needle position and the cutaway all affect the air/fuel mixture at low throttle openings. You can try dropping the needle one notch (raising the clip one notch), which will lean out the mixture. Then go for another ride along the same course and check your results. MC