Motorcycle Classics Blogs > Tech Corner

Tech Corner

Technical Q and A for classic motorcycle maintenance and repair.

1978 Suzuki GS550 Cylinder Not Firing


Editor's note: If you’re having trouble with that old Suzuki, BSA or BMW, Keith Fellenstein is your guy. From motorcycle tuning tips to detailed motorcycle engine repair, he can draw from a wealth of experience to help guide you to success. Send questions to: Keith’s Garage, 1503 SW 42nd St., Topeka, KS 66609, or send an e-mail with "Keith's Garage" as your subject.  

1978 Suzuki GS550 Cylinder Not Firing 

Q: I am the proud owner of a 1978 Suzuki GS550. When I purchased the motorcycle the number 2 cylinder was not firing. I checked for spark and that was good, but swapped out the plug for good measure. Next, I pulled the carbs and went through number 2 and installed new jets/gaskets. This didn’t fix my problem. With spark and fuel out of the picture, lack of compression due to worn valve guides/piston rings/cam lobe is the next logical conclusion, but there is a catch. It seems that after about 10 minutes of mild riding (6,000rpm) the bike changes tune to a throatier note and begins to pull a lot harder. After stopping the engine, the number 2 cylinder exhaust manifold is hot to the touch. Is there a simple fix here? - Doug/via email 

A: Your bike, like so many Japanese fours from that time period, uses two coils to fire four cylinders. In your case, one coil fires cylinders 1 and 4 and the other cylinders 2 and 3. You’ve already said that cylinder 3 is firing and that you have good spark at 2, so we can rule out that coil. Doing a compression check on all the cylinders would be a good thing. If you can’t do that you may be able to troubleshoot the problem like this: Change the plug out for a brand new one. Ride for a while, and before you get the power shift, stop and pull that plug. Examine the tip and see if it is wet with gas but not changed in color from the factory white. If the plug tip isn’t wet with gas, then that cylinder is not getting fuel. If it is wet, then that cylinder isn’t firing effectively. Continue riding until you notice the change in power, and then after riding a bit with all cylinders firing, pull the number 2 plug again. If it has been firing effectively, the color of the porcelain insulator should be anything from grey to black, with brown being the optimum color. It’s possible that for a number of reasons you aren’t getting good compression in that cylinder until the bike warms up. The first thing that comes to mind is perhaps the compression ring or rings are stuck in the piston, and only loosen up when the aluminum piston warms up enough to free the iron or chrome steel ring. Secondly, you could have worn rings, although you’d think that would show up in all the cylinders, not just one. With worn rings, the cylinder may not be getting enough compression until enough oil has built up to help seal the rings. MC